bengreen.eu Circle Device

 

Quick Reference

JSP Error in Jetty 9.4+

Upgrading Jetty to 9.4.2.v20170220 from 9.3.0.M1 meant that the Maven configuration failed because of a missing package: jetty-jsp. To get around this simply replace the reference to jetty-jsp to apache-jsp and add apache-jstl. Of course the variable ${jetty-version} for my setup is 9.4.2.v20170220.

<dependency>
	<groupId>org.eclipse.jetty</groupId>
	<artifactId>jetty-plus</artifactId>
	<version>${jetty-version}</version>
</dependency>
<dependency>
	<groupId>org.eclipse.jetty</groupId>
	<artifactId>jetty-annotations</artifactId>
	<version>${jetty-version}</version>
</dependency>
<dependency>
	<groupId>org.eclipse.jetty</groupId>
	<artifactId>apache-jsp</artifactId>
	<version>${jetty-version}</version>
	<scope>compile</scope>
</dependency>
<dependency>
	<groupId>org.eclipse.jetty</groupId>
	<artifactId>apache-jstl</artifactId>
	<version>${jetty-version}</version>
</dependency>

This information was easy to resolve after looking at the jetty project github pages which are updated regularly and have some very useful examples. See the references.

Quick Links: Techie Stuff | General | Personal | Quick Reference